Voice Gateway Technical Capabilities - Cognigy Documentation

Supported Protocols

The following protocols are supported:

Protocol Supported Functionality
SIP SIP signaling, as specified in IETF RFC 3261.
TLS The Transport Layer Security (TLS) is a cryptographic protocol that provides secure communication over a network. Voice Gateway supports TLS 1.2 and later versions. TLS 1.3 is preferred for optimal security.
SIP over TLS Partially encrypted SIP, as specified in IETF RFC 3261. Some servers may communicate unencrypted, depending on specific requirements.
SIPS Fully encrypted SIP, as specified in IETF RFC 3261. All servers in the communication chain use TLS for encrypted communication.
SIP over WebSockets SIP over secure WebSockets, as specified in RFC 7118.
RTP The Real-time Transport Protocol as specified in RFC 3550.
SRTP Encrypted media using the Secure Real-time Transport Protocol (SRTP), as specified in RFC 3711.
RTCP The RTP Control Protocol (RTCP) provides quality of service (QoS) statistics for RTP media streams.
Session Description Protocol (SDP) The Session Description Protocol (SDP), as specified in RFC 4566.
Offer/Answer Model with the Session Description Protocol (SDP) The offer or answer model for negotiating SIP sessions, as specified in RFC 3264.
DTMF The use of RTP payloads to carry DTMF events, as specified in RFC 2833.
SIP Digest Authentication SIP Digest Authentication challenges and authenticates SIP devices, as specified in RFC 8760.
SIPREC Acting as a SIPREC client or server to accomplish call recording, as specified in RFC 7866.
WebRTC clients Receiving calls from WebRTC clients, such as web browsers or native mobile apps.
DTMF - SIP INFO Receiving DTMF via SIP INFO, as specified in RFC 2976.
SIP OPTIONS OPTIONS pings to allow remote SIP gateways and Session Border Controllers (SBCs) to test the health of the Voice Gateway SBCs.
Session timers SIP session timers, as specified in RFC 4028.
SIP UPDATE The SIP UPDATE method to refresh SIP session.
STUN Session Traversal Utilities for NAT (STUN), as specified in RFC 5389.
Diversion Indication in SIP The Diversion header, as specified in RFC 5806.
SIP REFER Sending the SIP REFER method to transfer calls, as specified in RFC 3515. Receiving SIP REFER is not supported.

Supported Codecs

The following audio codecs are supported:

Features

Trunk management and Routing

Call Features

Call Management

STT and TTS providers

Call Recording and Storage

Call Quality Monitoring and Optimization

Technical Support

For any further or more specific questions about the Voice Gateway technical capabilities, contact Cognigy technical support.

Last modified on July 6, 2026.