## Supported Protocols

The following protocols are supported:

| Protocol | Supported Functionality |
| --- | --- |
| SIP | SIP signaling, as specified in [IETF RFC 3261](https://datatracker.ietf.org/doc/html/rfc3261). |
| TLS | The Transport Layer Security (TLS) is a cryptographic protocol that provides secure communication over a network. Voice Gateway supports TLS 1.2 and later versions. TLS 1.3 is preferred for optimal security. |
| SIP over TLS | Partially encrypted SIP, as specified in [IETF RFC 3261](https://datatracker.ietf.org/doc/html/rfc3261). Some servers may communicate unencrypted, depending on specific requirements. |
| SIPS | Fully encrypted SIP, as specified in [IETF RFC 3261](https://datatracker.ietf.org/doc/html/rfc3261). All servers in the communication chain use TLS for encrypted communication. |
| SIP over WebSockets | SIP over secure WebSockets, as specified in [RFC 7118](https://datatracker.ietf.org/doc/html/rfc7118). |
| RTP | The Real-time Transport Protocol as specified in [RFC 3550](https://datatracker.ietf.org/doc/html/rfc3550). |
| SRTP | Encrypted media using the Secure Real-time Transport Protocol (SRTP), as specified in [RFC 3711](https://datatracker.ietf.org/doc/html/rfc3711). |
| RTCP | The RTP Control Protocol (RTCP) provides quality of service (QoS) statistics for RTP media streams. |
| Session Description Protocol (SDP) | The Session Description Protocol (SDP), as specified in [RFC 4566](https://datatracker.ietf.org/doc/html/rfc4566). |
| Offer/Answer Model with the Session Description Protocol (SDP) | The offer or answer model for negotiating SIP sessions, as specified in [RFC 3264](https://datatracker.ietf.org/doc/html/rfc3264). |
| DTMF | The use of RTP payloads to carry DTMF events, as specified in [RFC 2833](https://datatracker.ietf.org/doc/html/rfc2833). |
| SIP Digest Authentication | SIP Digest Authentication challenges and authenticates SIP devices, as specified in [RFC 8760](https://datatracker.ietf.org/doc/html/rfc8760). |
| SIPREC | Acting as a SIPREC client or server to accomplish call recording, as specified in [RFC 7866](https://datatracker.ietf.org/doc/html/rfc7866). |
| WebRTC clients | Receiving calls from WebRTC clients, such as web browsers or native mobile apps. |
| DTMF - SIP INFO | Receiving DTMF via SIP INFO, as specified in [RFC 2976](https://www.rfc-editor.org/rfc/rfc2976). |
| SIP OPTIONS | OPTIONS pings to allow remote SIP gateways and Session Border Controllers (SBCs) to test the health of the Voice Gateway SBCs. |
| Session timers | SIP session timers, as specified in [RFC 4028](https://datatracker.ietf.org/doc/html/rfc4028). |
| SIP UPDATE | The SIP UPDATE method to refresh SIP session. |
| STUN | Session Traversal Utilities for NAT (STUN), as specified in [RFC 5389](https://datatracker.ietf.org/doc/html/rfc5389). |
| Diversion Indication in SIP | The Diversion header, as specified in [RFC 5806](https://datatracker.ietf.org/doc/html/rfc5806). |
| SIP REFER | Sending the SIP REFER method to transfer calls, as specified in [RFC 3515](https://datatracker.ietf.org/doc/html/rfc3515). Receiving SIP REFER is not supported. |

## Supported Codecs

The following audio codecs are supported:

- `G.711`(preferred):
  - `A-law`.
  - `U-law`.
- `OPUS`.
- `G.722`.

## Features

### Trunk management and Routing

- Transferring calls via [SIP REFER](https://datatracker.ietf.org/doc/html/rfc3515) or [SIP INVITE](https://datatracker.ietf.org/doc/html/rfc3261).
- Multiple SIP trunks per customer.
- Configuring SIP trunks with options like tech prefix, SIP Diversion header, Outbound authentication (including `REGISTER`).
- Routing calls based on trunk group, Direct Inward Dialing (DID), or DID range.
- Least-cost routing selection of outbound trunk.

### Call Features

- Custom SIP headers on inbound and outbound calls.
- Mid-call SIP INFO requests.
- P-Asserted-Identity header to identify caller.
- Receiving compact SIP headers.
- Receiving re-INVITE with no Session Description Protocol (SDP).
- [Answering machine detection](https://docs.cognigy.com/voice-gateway/references/verbs/amd).
- Configurable music on hold.
- Configurable [Atmosphere Sounds](https://docs.cognigy.com/ai/agents/develop/node-reference/voice/voice-gateway/parameter-details) playing in the background of the conversation.
- Configurable [Silence Overlay](https://docs.cognigy.com/ai/agents/develop/node-reference/voice/voice-gateway/parameter-details) playing background sounds when there’s a long pause in a call.
- [TTS streaming](https://docs.cognigy.com/voice-gateway/streaming) to reduce latency.

### Call Management

- [Creating outbound calls via REST API](https://docs.cognigy.com/voice-gateway/creating-outbound-calls).
- Performing operations on calls in progress via REST API.

### STT and TTS providers

- Many cloud-based and on-premises [speech providers](https://docs.cognigy.com/voice-gateway/references/tts-and-stt-vendors) are available, along with the option to integrate [custom speech API](https://docs.cognigy.com/voice-gateway/webapp/speech-services#add-custom-speech-vendors) tailored to your needs.
- [Fallback speech configuration](https://docs.cognigy.com/voice-gateway/webapp/applications#add-additional-tts-and-stt-vendor) if the primary vendor fails.

### Call Recording and Storage

- [Call recording](https://docs.cognigy.com/voice-gateway/webapp/recent-calls#call-recordings) via integration with a third-party SIPREC server.
- Pausing or resuming transcription and recording to avoid the collection of Personally Identifiable Information (PII).
- Call recording with no third-party components, [recordings streamed to the preferred cloud storage](https://docs.cognigy.com/voice-gateway/webapp/recent-calls#call-recordings).

### Call Quality Monitoring and Optimization

- Observability features include [tracing call events with open telemetry](https://docs.cognigy.com/voice-gateway/webapp/recent-calls).
- Visual view of [speech latency](https://docs.cognigy.com/voice-gateway/webapp/recent-calls#call-recordings) (TTS and STT) on each call.
- [Caching of TTS audio](https://docs.cognigy.com/voice-gateway/webapp/accounts#tts-prompt-caching) when possible to reduce costs.

## Technical Support

For any further or more specific questions about the Voice Gateway technical capabilities, contact [Cognigy technical support](https://docs.cognigy.com/help/get-help).

Last modified on July 6, 2026.
